Compile issue…

Home Discussions TB2 Compile issue…

This topic contains 8 replies, has 5 voices, and was last updated by  JohWil 1 year, 7 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #3167

    JaseM
    Participant

    I’m trying to compile the code with Arduino 1.6.3 with the most recent firmware. I’ve tried to re-name the DueTimer library after compiling issues but I’m still having problems. I’m getting the following error:

    Any ideas?

    #3168

    moshang
    Keymaster

    Hey Jase,

    From the first line of the error report it seems you have the board set to Arduino Uno – it should be Arduino Due. Things are a little less straight-forward with the latest IDE, as you have to download an additional package for Arduino Due support.

    Please see the note under “Upload” here https://groovesizer.com/tb2-resources/

    Let me know if you’re still stuck.

    #3455

    ploom2
    Participant

    hi
    i have a strange issue
    i can download attack , but not quartet

    the error i get is
    Groovesizer_TB2_132.ino:2:22: fatal error: MidiBase.h: No such file or directory
    compilation terminated.
    Error compiling.

    Midi library is installed , i cant find anything related to MidiBase.h

    any help would be appreciated
    also , when i plug in the tb2 my mac sometimes brings up a window for me to identify the keyboard… i still seem to be able to download attach though.

    #3456

    ploom2
    Participant

    strangely 132C downloads , it doesnt have the 2 x includes at the top of the source code

    maybe thats something i did…i was tinkering with things without a clue what i was doing.

    #3457

    moshang
    Keymaster

    That’s very odd, Ploom – have you tried downloading v132 firmware off the website again? It compiles fine this side, but I’m on PC and I don’t have a MAC to test with. I would think that it would try to identify the Arduino Due when you plug in the USB is that what you mean?

    #3458

    ploom2
    Participant

    i think everything is fine.
    i grabbed it again and it compiles and downloads

    when plugged into the native usb port my mac brings up a keyboard setup assistance window but on the programming usb port nothing pops up.

    im on osx 10.10.5

    #3507

    xendal
    Participant

    hello i am trying to compile the attack software and get this error.
    Arduino: 1.6.4 (Windows 7), Board: “Arduino Due (Programming Port)”

    arm-none-eabi-gcc: error: C:\Users\samsung\AppData\Local\Temp\build144262110233923545.tmp/core/syscalls_sam3.c.o: No such file or directory
    arm-none-eabi-gcc: error: C:\Users\samsung\AppData\Local\Temp\build144262110233923545.tmp/core.a: No such file or directory
    Error compiling.

    This report would have more information with
    “Show verbose output during compilation”
    enabled in File > Preferences.
    any help would be appreciated i am quite new to this still cheers

    #3510

    moshang
    Keymaster

    I don’t remember the exact error right now, but do you have the Due board installed in the IDE? See the note under Upload here: https://groovesizer.com/tb2-resources/

    #3574

    JohWil
    Participant

    The release of 132f

    I am pleaded to say that I’ve got serious help in the further coding of sequels to the release by Moshang of fw 132 by Liam Power. Here is the link to 132f Please tell us what you think.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.