midi sync

Home Discussions Alpha [MB] midi sync

Tagged: 

This topic contains 10 replies, has 3 voices, and was last updated by  markhadley 3 years, 4 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1322

    foehn
    Participant

    hi there,

    enjoying the groovesizer i wonder:

    how can i sync it to an external clock?

    groovesizer should be slaved and receive (and respond) to the external clock (bpm/start/stop)

    cheers

    daniel

    #1325

    moshang
    Keymaster

    Hey there Daniel,

    I’m not sure if you’re referring to the Groovesizer Alpha, or to the original Groovesizer mk1 (http://moshang.net/soundjeweler_blog/technique/groovesizer-diy-16-step-sequencer-and-synth/).

    If it’s the Alpha you’re referring to, it’s as simple as sending MIDI clock from the instrument/software you want to use as master, and connecting the MIDI out from the master to the MIDI in of the Groovesizer. The Groovesizer syncs to clock by default.

    MIDI sync is unfortunately not possible on the original mk1, because the serial RX line required for MIDI input is used for one of the buttons. I’ve changed this for the soon-to-be released mk1 kits – those will feature MIDI inputs and outputs, along with sync.

    #1327

    foehn
    Participant

    hey moshang,

    im talking about the groovesizer mk2 with the alpha 1.08 firmware.
    actually, i did send midiclock to the groovesizers midi-in.
    i was expecting the groovesizer to react, when im sending a Start/Stop/Continue
    message (FAH/FCH/FBH).
    but – to no avail. the groovesizer is running at own tempo, no matter what im doing with the clock signals.
    but, now that you cleard the air and i know that the groovesizer receives clock by default, i will experiment a little with it today. maybe its a faulty 6n137.
    ill report back when i have it up and running!

    • This reply was modified 3 years, 6 months ago by  foehn.
    #1331

    foehn
    Participant

    hey moshang,

    tried it with sending the midi clocl to the groovesizer.
    the groovesizer is not reacting to either start/stop or tempo.
    its just playing and playing in its own tempo. i think,
    when receiving midi clock, it should prevent tempo adjustments as well. but tempo adujstments work like there is no midi clock receivend. where can i look for possible errors now?

    #1335

    moshang
    Keymaster

    Hey again Daniel,

    Yeah, that doesn’t sound right. On receiving MIDI clock, the Groovesiser should immediately jump to the new tempo, and stop when it receives a stop command.

    Can you test whether the Groovesizer is receiving MIDI at all by sending it some notes? To do so, make sure you have the Note Entry option selected on the Preferences page (F4), then go back to Edit Mode and stop playback with F1. When you send notes to the Groovesizer now, you should see the sequencer advancing for every note it receives (just make sure you’re sending notes on any of the 16 channels besides the one selected for Trigger Out on the preferences page – the default trigger channel is 10).

    If the Groovesizer receives notes, but doesn’t respond to MIDI clock, it’s not receiving clock. I’ve been using this software as a light-weight way to send MIDI clock for testing.

    If you’re not receiving notes either, something is wrong on the harware side. It’s possible there’s a problem with the 6N137 as you suggest – have you double-checked its orientation? Re-check the soldering on the 6N137, as well as on the MIDI input jack.

    As an aside, I’ve just discovered that Reason and Cakewalk Sonar don’t ever stop sending MIDI clock, so after the Groovesizer receives a stop command, it will rewind, but immediately start playing again, because MIDI clock is still present.

    Let me know how you get along.

    #1345

    foehn
    Participant

    hey moshang,

    thank you for that elaborated response. thing is, i checked the midi cable.
    i checked if theres a clock (by plugging the cable out of the groovesizer and into the midibox SEQV4L. the SEQV4L recieves the clock and responds to it. plugging it back to the groovesizer – no effect.
    i checked if the groovesizer recieves midi (notes) like you proposed – no problem here. it works. i checked the connections with the midi port – but there seems nothing to be wrong. im a bit lost here šŸ™

    cheers

    daniel

    #1347

    foehn
    Participant

    hey moshang,

    the thing is fixed. it was a bad solder joint with the 6n137.
    funny thing, it did recieve midi nonetheless.
    sometimes its a mystery. but in the end, thats where the fun is – right?
    so, thank you very much for helping troubleshoot that.
    and – of course – a happy new year in advance šŸ™‚

    cheers

    #1348

    moshang
    Keymaster

    You’re welcome – I’m relieved the problem is solved. Thanks and Happy New Year to you too – 4 more hours to 2014 here in Taiwan ;^)

    #1638

    markhadley
    Participant

    hey moshang!
    i’ve noticed something a bit strange and after reading this wonder if it’s a bad solder or just a weird bug.
    when sending midi clock, it seems that the knob that usually controls note length doesn’t do anything.
    it works fine when on it’s on the internal clock, but stops working when it’s receiving clock. (this may be helpful or not: it doesn’t get stuck on whatever value the note length was previously set at; as soon it gets clock it just goes to the same note length every time and remains there regardless of the knob)
    any insight?

    thanks for the help!

    #1639

    moshang
    Keymaster

    Heya Mark,

    You’re right – the note length knob is inactive when the Groovesizer is slaved to MIDI clock. I don’t remember why I struggled to make it work under MIDI sync, but I’ll have a look at it again. In the meantime, setting the note length before you you start the external clock works consistently for me (do I understand correctly that you’re having trouble doing this?). Specifically, I run the sequence on the internal clock and set the note length, then turn on the external clock. Note length remains the same as what you just set. You’ll also find that, as you’d expect, on external clock saved patterns play back with the note length you set them at when saving.
    ***EDIT***
    Dang, just ran headlong into an old bug where note duration sometimes doesn’t get saved correctly the first time around (you can adjust note length again and resave as a work-around). I’ll put it back on the to-do list.

    • This reply was modified 3 years, 5 months ago by  moshang.
    #1676

    markhadley
    Participant

    with a bit more fiddling around i did get the note length to stick to where it was set if i run the internal clock first. sweet!

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.